Overgrowth

System Requirements

Check here the minimum and recommended System Requirements to run Overgrowth with no technical problems and test if you can run it.

Developer

Wolfire

Publisher

Wolfire

Platforms

Overgrowth Minimum System Requirements

  • Operational System: Windows XP
  • Processor: Intel Core2 Duo T6400 @ 2.00GHz / AMD Athlon 64 X2 Dual Core 4400+
  • Video Card: GeForce 7600 GT / Mobility Radeon X1600
  • RAM Free: 2 GB RAM
  • Disk Space (HD): 7 Gb Free
  • Directx Version: DirectX 9